Fedora Packages

perl-deprecate Subpackage of perl

Perl pragma for deprecating the inclusion of a module in core

"deprecate" pragma simplifies the maintenance of dual-life modules that will no longer be included in the Perl core in a future Perl release, but are still included currently. The purpose of the pragma is to alert users to the status of such a module by issuing a warning that encourages them to install the module from CPAN, so that a future upgrade to a perl which omits the module will not break their code.

Releases Overview

Release Stable Testing
Fedora Rawhide 0.04-509.fc41 -
Fedora 40 0.04-506.fc40 -
Fedora 39 0.04-502.fc39 -
Fedora 38 0.04-498.fc38 -
File a new bug report »
Package Info
  • Upstream: https://www.perl.org/
  • License(s): GPL-1.0-or-later OR Artistic-1.0-Perl
  • Maintainers: jplesnik, corsepiu, iarnell, ppisar, psabata, spot, rhughes, alexl, caolanm, mspacek

Related Packages

You can contact the maintainers of this package via email at perl dash maintainers at fedoraproject dot org.



Sources on Pagure