Fedora Packages

lua5.1-luv Subpackage of lua-luv

Bare libuv bindings for lua 5.1

This library makes libuv available to lua scripts. It was made for the luvit project but should usable from nearly any lua project. The library can be used by multiple threads at once. Each thread is assumed to load the library from a different lua_State. Luv will create a unique uv_loop_t for each state. You can't share uv handles between states/loops. The best docs currently are the libuv docs themselves. Hopefully soon we'll have a copy locally tailored for lua.

Releases Overview

Release Stable Testing
Fedora Rawhide 1.44.2.1-4.fc39 -
Fedora 39 1.44.2.1-4.fc39 -
Fedora 38 1.44.2.1-3.fc38 -
Fedora 37 1.44.2.1-1.fc37 1.44.2.1-1.fc37
EPEL 9 1.43.0.0-1.el9 -
EPEL 8 1.42.0.1-3.el8 -
File a new bug report »
Package Info
Related Packages

You can contact the maintainers of this package via email at lua-luv dash maintainers at fedoraproject dot org.



Sources on Pagure