Fedora Packages

gdb-gdbserver-14.2-12.fc41 in Fedora Rawhide

↵ Return to the main page of gdb-gdbserver
View build
Search for updates

Package Info (Data from x86_64 build)
🠗 Changelog
🠗 Dependencies
🠗 Provides
🠗 Files

Changelog

Date Author Change
2024-06-18 Kevin Buettner <kevinb at redhat dot com> - Remove gdb-core-open-vdso-warning.patch. This tests added by this patch are similar to those of upstream test gdb.base/vdso-warning.exp.
2024-06-18 Kevin Buettner <kevinb at redhat dot com> - 14.2-12 - Revise rpm-suggestions.py script so that message regarding a not-found 'rpm' module is output to stderr. (RHBZ 2275274)
2024-06-08 Python Maint <python dash maint at redhat dot com> - Rebuilt for Python 3.13
2024-06-06 Python Maint <python dash maint at redhat dot com> - 14.2-10 - Bootstrap for Python 3.13
2024-05-23 Kevin Buettner <kevinb at redhat dot com> - 14.2-9 - Revise rpm-suggestions.py script so that a message is printed when the 'rpm' module (found in the python3-rpm package) isn't found. In particular, the ModuleNotFoundError will be caught, avoiding a potential python import error. (RHBZ 2275274)
2024-05-22 Guinevere Larsen <blarsen at redhat dot com> - Remove gdb-fedora-libncursesw.patch, this workaround isn't needed anymore.
2024-05-15 Keith Seitz <keiths at redhat dot com> - 14.2-8 - Sync x86 disassembler with (proposed) gdb-15.1 release. (many authors, RHBZ 2277160)
2024-04-30 Keith Seitz <keiths at redhat dot com> - 14.2-7 - Remove bundled copy of libipt. - Remove bundled copy of libstdc++ pretty-printers. - Always include debuginfod support. - Purge RHEL < 8.
2024-04-25 Kevin Buettner <kevinb at redhat dot com> - 14.2-6 - Further changes for fixing RHBZ 2275274: Add a 'Requires: binutils' which is needed because gdb-add-index uses readelf and objcopy. Also, delete librpm related stuff since gdb/build-id.c no longer attempts to dlopen a librpm library. Add 'Recommends python3-rpm' so that rpm-suggestions.py will find the required python module.
2024-04-23 Kevin Buettner <kevinb at redhat dot com> - 14.2-5 - Add "Requires: which" for RHBZ 2275274.

Provides

  • gdb-gdbserver
  • gdb-gdbserver(x86-64)
  • libinproctrace.so()(64bit)

Files


Sources on Pagure